88cc death!

PlanetMinis Forums

88cc death!

This is a discussion on 88cc death! within the CRF50 forums, part of the General Talk category; Hi um I need some help. I installed a kamakazi 88cc kit with no head and Its ticking pretty loud, I did the valves with ...

Page 1 of 2 12 LastLast
Results 1 to 15 of 20

Thread: 88cc death!

  1. #1
    Member
    This user has no status.
     
    AcXr50's Avatar

    Join Date
    Dec 2006
    Location
    Federalway
    Posts
    53

    88cc death!

    Hi um I need some help. I installed a kamakazi 88cc kit with no head and Its ticking pretty loud, I did the valves with the correct feeler gauge and it still ticks I do have fmf exaust now , they said in the directions that a new oil pump is recemended . i really dont know a whole lot so If anyone has any advice I would love to hear it.





    thank you

  2. #2
    Senior Member
    This user has no status.
     
    MX50's Avatar

    Join Date
    Jun 2006
    Location
    Stockton,Ca
    Posts
    298
    Check your timing?

  3. #3
    Banned
    This user has no status.
     
    dragndave's Avatar

    Join Date
    Aug 2006
    Location
    south florida
    Posts
    773
    make sure your exhaust isnt leaking

  4. Remove Advertisements
    PlanetMinis.com
    Advertisements
     

  5. #4
    Senior Member
    This user has no status.
     
    veloc1ty's Avatar

    Join Date
    Oct 2006
    Location
    Texas
    Posts
    265
    "I installed a kamakazi 88cc kit with no head and Its ticking pretty loud"

    theres your problem! you forgot the head . but really, double check the valves, and be sure the piston isn't hitting. also some kits just click

  6. #5
    Senior Member
    This user has no status.
     
    yamaha's Avatar

    Join Date
    Jul 2006
    Location
    locust grove, va
    Posts
    2,056
    tighten the head more

  7. #6
    Senior Member
    This user has no status.
     
    turboglenn's Avatar

    Join Date
    Jul 2005
    Location
    Omaha, NE
    Posts
    1,959
    the valves on big bore kits tick noticably louder thana stock motor does anyway, you may just be hearing the normal sounds of an 88 kit... do you have a friend witha BBK to compare sounds to?

  8. #7
    Senior Member
    This user has no status.
     
    ryan2282's Avatar

    Join Date
    Jan 2005
    Location
    Lake Orion, Mi
    Posts
    5,906
    Ya 9 times out of 10 after taking the head aprt and putting iot back together with the proper clearance of the valves dont do much. I set mine all the time and upon starting to check all was well the valves ticked louder. usually they'll loosen up a bit so check them again. if not then yes the more cc's you go and other cam will make valves tick louder. just get used to it.

  9. #8
    Senior Member
    This user has no status.
     
    nerfkhat's Avatar

    Join Date
    May 2006
    Location
    aurora, co
    Posts
    126
    oooh i got the answer! you forgot the dowel pins between head and block. i did the same thing....i thought it was valves and adjusted them twice...it might be between the head and cylinder but i would check the stock cylinder to see if the dowels are still in there..i forgot which ones i left on the cylinder but i believe its the one between the head and cylinder..

  10. #9
    Senior Member
    This user has no status.
     
    2006klx110rider's Avatar

    Join Date
    Oct 2006
    Location
    Apple Valley,California
    Posts
    706
    timing chain

  11. #10
    Senior Member
    This user has no status.
     
    yamaha's Avatar

    Join Date
    Jul 2006
    Location
    locust grove, va
    Posts
    2,056
    timing chain doesnt tick it makes a weird noise like scrathing almost

  12. #11
    Banned
    This user has no status.
     
    dragndave's Avatar

    Join Date
    Aug 2006
    Location
    south florida
    Posts
    773
    scrathing? thats a new one for me

  13. #12
    Senior Member
    This user has no status.
     
    yamaha's Avatar

    Join Date
    Jul 2006
    Location
    locust grove, va
    Posts
    2,056
    idk how to explain timing chain noises lol.

  14. #13
    Member
    This user has no status.
     
    AcXr50's Avatar

    Join Date
    Dec 2006
    Location
    Federalway
    Posts
    53
    Hey thanks guys I guess I just need to not eat for awhile and get a good head.

  15. #14
    Senior Member
    This user has no status.
     
    50smasher's Avatar

    Join Date
    Jul 2006
    Location
    stockton,ca
    Posts
    269
    i got a kitaco 88 and its always ticked. but theres nothing wrong with it
    Willies Moto World #47

    Ride Nastty

    OCRanch.tv

  16. #15
    Senior Member
    is Teaching math
     
    Z50King's Avatar

    Join Date
    Sep 2004
    Location
    Glendale, CA
    Posts
    10,011
    put your stock air box back on, and 99% of the time the "tick" will go away. your hearing the intake valve open and shut because you probably have a new K&N or foam filter.

Page 1 of 2 12 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Sponsored Links

Powered by vBadvanced CMPS v4.3.0