New Piranha 140cc not running correctly - hardly at all - very disappointed

PlanetMinis Forums

New Piranha 140cc not running correctly - hardly at all - very disappointed

This is a discussion on New Piranha 140cc not running correctly - hardly at all - very disappointed within the Honda CRF70 forums, part of the General Talk category; Help! I took the XR70 with 140cc Piranha out Saturday and it's not running correctly. I can't even ride it as it just won't keep ...

Results 1 to 3 of 3
  1. #1
    Junior Member
    This user has no status.
     
    Big_GRR's Avatar

    Join Date
    Jan 2017
    Location
    San Jose, CA
    Posts
    4

    New Piranha 140cc not running correctly - hardly at all - very disappointed

    Help! I took the XR70 with 140cc Piranha out Saturday and it's not running correctly. I can't even ride it as it just won't keep running. I had my son with his big boot kick-start it for me as it almost tore my calf off the last time I tried. This bike has the new Piranha 140cc engine I bought last year from TboltUSA brand new. It came with a 22mm mikuni (not sure if it Chinese or Japanese) Carburetor. It acted like the low speed jet was clogged as it favored more choke to run. I removed the carb and all looked OK. I also installed a new spark plug with no difference. I did bend the float tang down a bit as it looked like not much distance/movement between contacting the float valve and fully "up." Again, no difference - thinking this may solve a running rich condition. The air jet was adjusted to a little over One Turn out. Anyway, I'm guessing that there may be a problem with 1) Coil, 2) Carb, 3) Pipe (cost order). I went with the stock pipe (with spark arrestor removed) because it fit better (no side cover issues). Yes, I know (dirtbkr) I was warned that the stock pipe would "choke" down the bigger engine, but I figured I could live with a little less power.

    So, am I on the right track? I didn't check the valve clearance. Could that be the problem? Could it be a timing issue? Maybe somebody with Piranha 140 experience will know. P.S. I installed a Lifan 125cc motor in a previous build and it ran great with the stock pipe. Maybe I should have went with the Lifan.

    Thanks for all comments and advice.

    Later Edit:
    I was just on the Tbolt site looking at 22mm Mikunis. The notes state:
    - Brass fuel/Air screw is located bottom front (set to 2.5 turns out)

    Mine was about one turn out (as most of the Keihins I have owned). Could this (1 turn vs 2.5 turns) be the answer?

    Also, in looking for coils I see coil/cdi combos. So the CDI could be the culprit.

    If it is the air screw, does anybody know if there are any aftermarket jets with knob attachment? (So I can more easily adjust it while it is running).

    Last edited by Big_GRR; 03-21-2017 at 12:09 AM. Reason: Add another question

  2. #2
    Senior Member
    is Riding Minis
     
    Trailingpickles's Avatar

    Join Date
    Mar 2013
    Location
    Central Ontario Canada
    Posts
    547
    I was gonna guess coil. Vince will chime in here later I'd imagine

  3. #3
    Super Moderator
    is grateful again...
     
    dirtbkr188's Avatar
    Supporting Member

    Join Date
    May 2004
    Location
    New Jersey
    Posts
    8,183
    Quote Originally Posted by Big_GRR
    ...So I can more easily adjust it while it is running...


    Here you go

    I also replied to your thread over on TT
    - dirtbkr188 -



Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. What 12v battery are you running with the Piranha 140cc in a CT70?
    By davegoround in forum Z50, CT70 and JDM Monkeybikes
    Replies: 2
    Last Post: 03-11-2017, 01:05 PM
  2. 70cc not running correctly. please help me out!!
    By CLUKEY03 in forum Honda CRF70
    Replies: 2
    Last Post: 05-08-2015, 12:11 AM
  3. 140cc Piranha
    By meatball1196 in forum Roost Area
    Replies: 3
    Last Post: 02-16-2011, 12:36 PM
  4. Piranha 140cc Engine
    By Polkowski in forum Chinese/Import Minis - General Discussion
    Replies: 3
    Last Post: 10-21-2010, 09:45 AM
  5. Piranha 140cc engine
    By ride1226 in forum CRF50
    Replies: 17
    Last Post: 04-05-2010, 07:07 PM

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Sponsored Links

Powered by vBadvanced CMPS v4.3.0