New guy here with a 1981 CT 70

PlanetMinis Forums

New guy here with a 1981 CT 70

This is a discussion on New guy here with a 1981 CT 70 within the Z50, CT70 and JDM Monkeybikes forums, part of the General Talk category; New guy here with a 1981 CT 70. The engine did not turn over so I pulled the top end apart right away. The piston ...

Page 1 of 5 123 ... LastLast
Results 1 to 15 of 66
Like Tree3Likes

Thread: New guy here with a 1981 CT 70

  1. #1
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76

    New guy here with a 1981 CT 70

    New guy here with a 1981 CT 70. The engine did not turn over so I pulled the top end apart right away.

    The piston was stuck due to rusted rings, also the valves were gunked up & pitted. Gas tank is varnished up pretty bad, wouldnt ya know it so was the carb.

    I had cleaned up the cylinder immediatly and had it inspected @ my local machine shop. The cylinder was honed & measured. Turns out its within spec of using a stock piston!

    I ordered a new Art Piston & OEM Honda rings. Also ordered a new valve kit with springs. This will be returning back to its original condition.

    My exhaust pipe is rusted @ the header/muffler connection, so Im looking for an original 1981 exhaust to replace mine. Any help sourcing one would be much appreciated.

    Parts are on order, there will be more restoration to come!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20170415_180342_1492672440141.jpg 
Views:	104 
Size:	974.7 KB 
ID:	207473   Click image for larger version. 

Name:	20170415_180551_1492672471833.jpg 
Views:	94 
Size:	4.06 MB 
ID:	207481   Click image for larger version. 

Name:	20170415_225553_1492673218214.jpg 
Views:	93 
Size:	4.42 MB 
ID:	207489   Click image for larger version. 

Name:	20170417_121909_1492673254142.jpg 
Views:	97 
Size:	4.14 MB 
ID:	207497   Click image for larger version. 

Name:	20170415_223517_1492673298349.jpg 
Views:	95 
Size:	4.59 MB 
ID:	207505  

    Click image for larger version. 

Name:	20170416_235329_1492673351302.jpg 
Views:	102 
Size:	3.63 MB 
ID:	207513   Click image for larger version. 

Name:	20170418_111521_1492673408438.jpg 
Views:	102 
Size:	3.43 MB 
ID:	207521   Click image for larger version. 

Name:	20170417_130655_1492673462477.jpg 
Views:	103 
Size:	3.35 MB 
ID:	207529   Click image for larger version. 

Name:	20170417_163847_1492673521020.jpg 
Views:	97 
Size:	3.96 MB 
ID:	207537   Click image for larger version. 

Name:	20170415_181129_1492673571250.jpg 
Views:	105 
Size:	4.10 MB 
ID:	207545  

    Last edited by SEAHAWKS; 04-20-2017 at 02:35 AM.

  2. #2
    Senior Member
    This user has no status.
     
    kirrbby's Avatar

    Join Date
    Aug 2014
    Location
    Davison Mi.
    Posts
    431
    Those exhausts have gone on the NLA list and the ones that are out there are expensive...3-400+
    Yours is typical...Rusted right in half at the asbestos guard bushing. Don't scrap it. It's worth having it repaired. Over on lilhonda we have started discussing some common repairs. https://lilhonda.com/webboard/showth...804&highlight=

  3. #3
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    Do you know if a CRF 50 exhaust pipe will work on these ct70 heads?

  4. Remove Advertisements
    PlanetMinis.com
    Advertisements
     

  5. #4
    Senior Member
    This user has no status.
     
    kirrbby's Avatar

    Join Date
    Aug 2014
    Location
    Davison Mi.
    Posts
    431
    I think it would mount up to the head, you'd just have to sort out how to hang it on the frame.

  6. #5
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    Which gasket kits work for my bike? I cant find a specific 1981 ct70 kit on ebay?

  7. #6
    Senior Member
    This user has no status.
     
    kirrbby's Avatar

    Join Date
    Aug 2014
    Location
    Davison Mi.
    Posts
    431
    There's nothing remarkable about the 81's that I know of. Any kit for early, CT70's...6volt, should work fine.

  8. #7
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    I found this to keep the 70 company! A little honda qa50. The kickstart spring is bad & 2nd gear slips while riding.

    https://youtu.be/tt1MyI-pWkY
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20170420_181724_1492751192315.jpg 
Views:	104 
Size:	4.76 MB 
ID:	207625   Click image for larger version. 

Name:	20170420_181732_1492751214244.jpg 
Views:	115 
Size:	918.1 KB 
ID:	207633   Click image for larger version. 

Name:	20170420_181641_1492751249446.jpg 
Views:	108 
Size:	4.50 MB 
ID:	207641  

  9. #8
    Junior Member
    This user has no status.
     
    Tweakin's Avatar

    Join Date
    Dec 2016
    Location
    Seattle, WA
    Posts
    26
    Welcome to the forum! By the looks of your screen name possibly we are in the same area, I live south of Seattle.

  10. #9
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    Oh thats cool, im up north in Mukilteo. I got my little honda 50 tore down until parts come in. I scored some NOS gears, im more anxious than my kids...ha ha haaa....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20170423_172356_1493241791143.jpg 
Views:	106 
Size:	4.16 MB 
ID:	208345   Click image for larger version. 

Name:	20170423_170234_1493241823702.jpg 
Views:	107 
Size:	4.77 MB 
ID:	208353   Click image for larger version. 

Name:	20170423_120514_1493241879761.jpg 
Views:	107 
Size:	3.41 MB 
ID:	208361   Click image for larger version. 

Name:	20170423_103908_1493241931172.jpg 
Views:	113 
Size:	1.06 MB 
ID:	208369  

  11. #10
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    My parts arrived from dratv.com, I installed my NOS Honda piston & rings for the CT70.

    The new valves, hd springs, seals, race cam & valve spring compressor also arrived.

    I also cleaned up the varnished crusty stuff inside my fuel tank with apple cider vinegar. Then continued on to sealing it up with the Kreem tank liner.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20170502_182105_1493990441744.jpg 
Views:	101 
Size:	4.06 MB 
ID:	208777   Click image for larger version. 

Name:	20170502_195408_1493990515824.jpg 
Views:	111 
Size:	1.55 MB 
ID:	208785   Click image for larger version. 

Name:	20170502_204807_1493990553934.jpg 
Views:	102 
Size:	4.03 MB 
ID:	208793   Click image for larger version. 

Name:	20170502_205446_1493990598551.jpg 
Views:	106 
Size:	2.84 MB 
ID:	208801   Click image for larger version. 

Name:	20170502_205221_1493990638185.jpg 
Views:	103 
Size:	2.84 MB 
ID:	208809  

    Click image for larger version. 

Name:	20170502_210224_1493990678576.jpg 
Views:	100 
Size:	3.95 MB 
ID:	208817   Click image for larger version. 

Name:	20170502_211405_1493990736255.jpg 
Views:	105 
Size:	3.96 MB 
ID:	208825   Click image for larger version. 

Name:	20170421_220754_1493990879171.jpg 
Views:	109 
Size:	2.28 MB 
ID:	208833   Click image for larger version. 

Name:	20170421_220743_1493990968310.jpg 
Views:	97 
Size:	4.04 MB 
ID:	208841   Click image for larger version. 

Name:	20170421_220946_1493991081364.jpg 
Views:	103 
Size:	3.98 MB 
ID:	208849  


  12. #11
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    I made a few youtube videos of the Kreem tank prep and final tank seal process. New tank are around 100.00, my tank liner & apple cider vineager cost much less.

    Theres enough Kreem tank liner left over to seal my QA50 and Z50 tanks also!

    https://youtu.be/Xa1A1fuPslU

    https://youtu.be/trmxTMMdi4c
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20170423_164928_1493991615855.jpg 
Views:	114 
Size:	2.27 MB 
ID:	208857   Click image for larger version. 

Name:	20170422_200939_1493991681400.jpg 
Views:	108 
Size:	3.97 MB 
ID:	208865   Click image for larger version. 

Name:	20170422_200943_1493991728009.jpg 
Views:	106 
Size:	4.07 MB 
ID:	208873   Click image for larger version. 

Name:	20170426_223150_1493991794540.jpg 
Views:	113 
Size:	2.19 MB 
ID:	208881   Click image for larger version. 

Name:	20170427_110753_1493991946195.jpg 
Views:	107 
Size:	3.96 MB 
ID:	208889  


  13. #12
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    My bike is nearly finished, just waiting for my new exhaust from dratv.com.

    Yesterday I charged my new 6 volt battery installed it & tried testing the lights but nothing turns on.

    My harness looks all intact and connected properly. Do the lights only turn on when the bike is running?

  14. #13
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    Heres a few pics for yall to see. The lights still have me confused. I filled up the battery with acid, waited an hour, charged it for 4 hours...... installed battery, turned the key on & no lights, blinkers, or horn.

    What should I check next?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20170508_212503_1494337011257.jpg 
Views:	120 
Size:	3.64 MB 
ID:	209297   Click image for larger version. 

Name:	20170508_183928_1494337032820.jpg 
Views:	117 
Size:	2.83 MB 
ID:	209305   Click image for larger version. 

Name:	20170508_165450_1494337059008.jpg 
Views:	118 
Size:	3.00 MB 
ID:	209313   Click image for larger version. 

Name:	20170508_161702_1494337088914.jpg 
Views:	118 
Size:	3.98 MB 
ID:	209321   Click image for larger version. 

Name:	20170507_160509_1494337150392.jpg 
Views:	116 
Size:	898.7 KB 
ID:	209329  


  15. #14
    Senior Member
    This user has no status.
     
    kirrbby's Avatar

    Join Date
    Aug 2014
    Location
    Davison Mi.
    Posts
    431
    Only half of your lighting works from the battery. The rest is run directly from the stator using AC power. I'm not sure what's what on a 81. Turn signals are definitely run from the battery, maybe the horn and a couple speedo lights. Not sure about brake and tail light. Check your bulbs for sure, and everything needs a good clean ground.

  16. #15
    Member
    This user has no status.
     
    SEAHAWKS's Avatar

    Join Date
    Apr 2017
    Posts
    76
    I guess all my lightbulbs are burned out then.

Page 1 of 5 123 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. New guy/ Help with mods please-houston,tx guy here
    By Smokey1 in forum KLX110, DRZ110, TTR90
    Replies: 2
    Last Post: 01-07-2015, 07:40 AM
  2. Are you a CRF50 guy or an ATC70 guy?
    By theraymondguy in forum Off Topic
    Replies: 5
    Last Post: 05-07-2014, 04:49 PM
  3. 1981 xr80 value
    By Jarret53 in forum Vintage Honda XR75 and JDM Vertical Motors
    Replies: 13
    Last Post: 09-29-2013, 06:57 PM
  4. 1981 z50
    By electricflo in forum Z50, CT70 and JDM Monkeybikes
    Replies: 2
    Last Post: 04-19-2012, 07:01 AM
  5. 1981 cr80
    By ryan13254 in forum 2 Stroke Pitbikes
    Replies: 3
    Last Post: 03-19-2012, 05:41 PM

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Sponsored Links

Powered by vBadvanced CMPS v4.3.0